People with car benefit ending in April before 06/04/26 are failing to calculate

Incident Report for People First

Identified

The root cause has been identified and a fix is in progress. We are not yet able to conform timescales on a hot fix at this time. A further update will be provided later today.

If you need urgent support with this matter please raise this with our Service Desk.
Posted Apr 07, 2026 - 14:29 UTC

Investigating

We are currently investigating an issue where employees with a car benefit ending in April (before 06/04/26) are failing to calculate in Payroll.

Our development team is actively investigating the cause and we will provide further updates as more information becomes available.
Posted Apr 07, 2026 - 11:16 UTC
This incident affects: People First (UK Application) and API (UK API).