We are continuing to monitor for any further issues.
Posted Sep 09, 2025 - 16:26 UTC
Monitoring
We enabled mitigations and scaling to improve performance at 16:00 and processing has now returned to normal levels.
We will continue to investigate the root cause of these issues.
Posted Sep 09, 2025 - 16:26 UTC
Update
We believe that we have identified a cause for these performance issues and are in the process of implementing actions to mitigate this.
Posted Sep 09, 2025 - 14:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 09, 2025 - 14:43 UTC
Investigating
We are currently investigating a performance issue within the People First Platform, focusing on identifying its root cause and implementing necessary optimisations to enhance user experience. We will keep you updated on our progress and any developments as we work to resolve this issue.
Posted Sep 09, 2025 - 14:14 UTC
This incident affected: People First (UK Application) and API (UK API).