Intermittent issue affecting UK users

Incident Report for People First

Resolved

We have identified the cause of this morning's performance issues and applied mitigations to restore stability. A permanent fix is scheduled for deployment this evening to prevent further occurrences.
Posted Sep 04, 2026 - 15:05 UTC

Identified

We have now identified the root cause of some performance spikes seen this morning from 11:30am UK time. System performance has now stabilised and we are continuing to monitor and work through possible mitigations.
Posted Sep 04, 2026 - 11:53 UTC

Investigating

UK users on the *.people-first.com domain are currently encountering intermittent errors, impacting experience on the platform. Our team of engineers are actively investigating the issue, to swiftly identify and rectify the root cause.
Posted Sep 04, 2026 - 11:13 UTC
This incident affected: People First (UK Application) and API (UK API).