A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2026 - 17:30 UTC
Update
We are continuing to investigate the recent service instability. As part of our remediation work, our Cloud Platform team has moved the affected service onto new infrastructure, upgrading it to a higher‑capacity plan with increased memory. While this change has not fully resolved the issue, it has improved overall stability and performance.
Our engineering teams are actively continuing their investigation to identify the root cause and implement a permanent fix. We will provide further updates as more information becomes available.
Posted Jan 29, 2026 - 12:15 UTC
Identified
We are currently investigating a number of avenues to investigate the current performance issues as a priority.. We are looking to schedule fixes as soon as possible for known errors. Updates on timescales will be provided shortly.
Posted Jan 29, 2026 - 11:57 UTC
Investigating
We are currently investigating a performance issue within the People First Platform, focusing on identifying its root cause and implementing necessary optimisations to enhance user experience. We will keep you updated on our progress and any developments as we work to resolve this issue.
Posted Jan 29, 2026 - 10:41 UTC
This incident affected: People First (UK Application) and API (UK API).