People First Production Performance issues

Incident Report for People First

Resolved

This incident is resolved. Enhanced monitoring has determined that the mitigations remain stable and we are confident this is now fully resolved.
Posted Aug 07, 2026 - 15:38 UTC

Update

Mitigation has now been put in place to restore availability of the system, we are continuing to monitor the situation closely, but system availability has now been restored.
Posted Aug 07, 2026 - 13:32 UTC

Update

We are aware that there have been temporary outages over the last 30 Minutes. We are currently conducting mitigations and investigations into the root cause.
Posted Aug 07, 2026 - 13:01 UTC

Update

We are continuing to monitor the service, which is currently operating normally and remains healthy. Since the services were restarted, some users may experience slower-than-usual login times initially; however, once logged in, system performance should return to normal.
Posted Aug 07, 2026 - 10:44 UTC

Monitoring

Mitigation has now been put in place to restore availability of the system, we are continuing to monitor the situation closely, but system availability has now been restored.
Posted Aug 07, 2026 - 08:58 UTC

Identified

We are currently experiencing a full outage affecting UK customers accessing the People First service via the *.people-first.com domain. Users are unable to access the service at this time.

Our engineering teams are actively investigating the root cause and working to restore service as quickly as possible. We understand the impact this is having and appreciate your patience and understanding while we work to resolve the issue.

Further updates will be provided as soon as more information becomes available.
Posted Aug 07, 2026 - 08:01 UTC

Update

We are currently activating a mitigation process that should restore system availability. Further updates will be provided shortly
Posted Aug 07, 2026 - 07:58 UTC

Investigating

We are currently investigating a performance issue within the People First Platform, focusing on identifying its root cause and implementing necessary optimisations to enhance user experience. We will keep you updated on our progress and any developments as we work to resolve this issue.
Posted Aug 07, 2026 - 07:16 UTC
This incident affected: People First (UK Application) and API (UK API).