People First EU Production slowness
Incident Report for People First
Resolved
Microsoft have resolved underlying issue and service has returned to normal.
Posted Apr 05, 2024 - 18:29 UTC
Update
Microsoft are continuing to investigate the intermittent issue. They are working through changes to alleviate impact.

The next update will be provided in 2 hours, or as events warrant
Posted Apr 05, 2024 - 11:40 UTC
Investigating
We are aware of a Microsoft issue that may cause intermittent issues for our customers in the EU.
This could cause you timeout issue or slow perfomance.

Microsoft are working on a fix and the next update will be provided in 2 hours, or as events warrant
Posted Apr 05, 2024 - 08:35 UTC
This incident affected: People First (EU Application).