SMP is currently not calculating for all employees with maternity absences.
Incident Report for People First
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 17:35 UTC
Monitoring
The issue is now resolved, however further work is required to correct any data affected by the problem. Further updates will be provided on the progress of this.
Posted Nov 07, 2024 - 15:16 UTC
Update
The fix is being built and prepared for release to our production environments.
Posted Nov 07, 2024 - 10:54 UTC
Update
The issue is being investigated and a possible fix is being developed and tested. We're hoping to have this released today.
Posted Nov 06, 2024 - 12:11 UTC
Identified
This issue will impact ALL customers using Statutory absence.
Customers impacted by this issue will have statutory absence exceptions raised preventing payment.

What is the issue:
When the absence policy settings are updated and this triggers ripple down (Creating a change to an org or department filtering down to a job) any Statutory supplementary field data is removed from the absence payroll domain resulting in statutory exceptions being raised due to the system not being able to determine eligibility (Such as expected birth date, actual birth date, matching date)

Work around:
The absence booking form will contain the lost information, update the dates to the following day, save and then revert back to the correct dates. The absence will calculate the data as expected.
Posted Nov 05, 2024 - 16:19 UTC
This incident affected: People First (Payroll).