Jobs is currently unavailable for UK users
Incident Report for People First
Resolved
This incident has been resolved.
Posted Dec 10, 2018 - 09:53 UTC
Investigating
There is currently an issue affecting UK customers where they are unable to log into the people first Jobs service. Our engineers are investigating.
Posted Dec 10, 2018 - 09:31 UTC
This incident affected: People First (UK Application) and API (UK API).